Assign users case-insensitively by displayname, username and email #2196

Open
opened 7 months ago by xeruf · 12 comments
xeruf commented 7 months ago

When assigning new users, I can currently only select by E-Mail.
It would be good if I can filter by both mail and name, and the name is displayed in the suggestions.

When assigning new users, I can currently only select by E-Mail. It would be good if I can filter by both mail and name, and the name is displayed in the suggestions.
Owner

That's already implemented. Users need to explicitely enable it in their settings though:

image

That's already implemented. Users need to explicitely enable it in their settings though: ![image](/attachments/cd3d2afd-c1a4-4320-8b4f-ddf48fede62e)
konrad closed this issue 6 months ago
xeruf commented 6 months ago
Poster

Nope, I have that Checkbox enabled and it still does not work, at least on unstable.
Reproduced on try.

Nope, I have that Checkbox enabled and it still does not work, at least on unstable. Reproduced on try.
xeruf reopened this issue 6 months ago
konrad added the kind/bug label 6 months ago
konrad closed this issue 6 months ago
Owner

Looks like the settings were only taken into account when searching globally for users, not when searching for users with access to a list.

Fixed in 382a7884be - please check with the next unstable build if the problem went away.

Looks like the settings were only taken into account when searching globally for users, not when searching for users with access to a list. Fixed in https://kolaente.dev/vikunja/api/commit/382a7884be1f37da5c8f657c4b17316d8691dd59 - please check with the next unstable build if the problem went away.
xeruf commented 6 months ago
Poster

yes, it works now on 0.18.1+2040-9bbaa67eec but still two issues:

  • the display name should be shown in the autocompletion box (ideally plus avatar), not the email
  • the search should be case-insensitive
yes, it works now on `0.18.1+2040-9bbaa67eec` but still two issues: - the display name should be shown in the autocompletion box (ideally plus avatar), not the email - the search should be case-insensitive
xeruf reopened this issue 6 months ago
Owner

The display name is now shown in the autocomplete box since 65fd2f14a0.

Case-insensitive search is another topic and depends on the database used (with mariadb and sqlite the search is already case-insensitive). A seperate backlog item exists for that.

The display name is now shown in the autocomplete box since https://kolaente.dev/vikunja/frontend/commit/65fd2f14a067ea9d79b352af00f3c316be883fdf. Case-insensitive search is another topic and depends on the database used (with mariadb and sqlite the search is already case-insensitive). A seperate backlog item exists for that.
konrad closed this issue 5 months ago
xeruf commented 5 months ago
Poster

Thank you :)
We use postgres for scalability, and the case-insensitive search would be a great feature to always have :)

And you should also be able to search by username/e-mail, not just displayname.
Woops sorry, that option exists, but we really need the ability to make it default, could be simply an instance-wide config option.

And don't forget to make new releases ;)

Thank you :) We use postgres for scalability, and the case-insensitive search would be a great feature to always have :) ~~And you should also be able to search by username/e-mail, not just displayname.~~ Woops sorry, that option exists, but we really need the ability to make it default, could be simply an instance-wide config option. And don't forget to make new releases ;)
xeruf reopened this issue 5 months ago
xeruf changed title from Assign users by displayname to Assign users case-insensitively by displayname, username and email 5 months ago
Owner

And you should also be able to search by username/e-mail, not just displayname.

But that already works? Displayname and email depend on a setting of the individual users though.

> And you should also be able to search by username/e-mail, not just displayname. But that already works? Displayname and email depend on a setting of the individual users though.
xeruf commented 5 months ago
Poster

I corrected myself, you were too quick ;)

Furthermore, a (potentially trimmed) list of all available people (including avatars, idk if that is supposed to work already?) should be shown when clicking into the assignee field, like in Wekan.

I corrected myself, you were too quick ;) Furthermore, a (potentially trimmed) list of all available people (including avatars, idk if that is supposed to work already?) should be shown when clicking into the assignee field, like in Wekan.
xeruf commented 4 months ago
Poster

Furthermore it would be handy to be able assign users by email and displayname via Quick Add Magic - for the email even without the domain if that is unambiguous (would be perfect for our case, as every user signs in with his company mail and the mail-schema is well known - so if the mail is test@domain.com mentioning @test should assign that user)

Furthermore it would be handy to be able assign users by email and displayname via Quick Add Magic - for the email even without the domain if that is unambiguous (would be perfect for our case, as every user signs in with his company mail and the mail-schema is well known - so if the mail is `test@domain.com` mentioning `@test` should assign that user)
xeruf commented 4 months ago
Poster

Case-insensitive matching is a requirement here, assigning people is still quite janky.
And finding someone by e-mail-address still does not work, only if I enter the full address which is cumbersome :/

Case-insensitive matching is a requirement here, assigning people is still quite janky. And finding someone by e-mail-address still does not work, only if I enter the full address which is cumbersome :/
Owner

Case-insensitive matching was implemented in the meantime. Searching for users via email is designed to only work with the full email address to avoid searching for "@" and getting a list of all users on an instance. I think it should be fine to lax this when searching for assignees as these are usually already known since they were added to a team or explicitely to the list already.

Case-insensitive matching was implemented in the meantime. Searching for users via email is designed to only work with the full email address to avoid searching for "@" and getting a list of all users on an instance. I think it should be fine to lax this when searching for assignees as these are usually already known since they were added to a team or explicitely to the list already.
xeruf commented 4 months ago
Poster

just tested in try - it seems the name matches case-insensitively, but I have to enter the full name - there is no autocompletion:
e.g. when selecting a task, clicking assign user and typing "de" there is no suggestion

just tested in try - it seems the name matches case-insensitively, but I have to enter the full name - there is no autocompletion: e.g. when selecting a task, clicking assign user and typing "de" there is no suggestion
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: vikunja/frontend#2196
Loading…
There is no content yet.