Label Issues #603

Closed
opened 2 weeks ago by Gensokian · 19 comments

Over time I noticed some issues with labels.

  1. When setting a label inside a task and confirming the label creation with enter, the labels disappear from the list until the list is reloaded

  2. When editing the color of a Label in the Label editor, the color change applies directly, and seems saved, but on reload all changes are reverted.

  3. The Tags don't seem do be sorted in any way making it difficult to maintain an overview.

  4. Maybe Add an ability to group the Tags by Namespace/List they are in?

Over time I noticed some issues with labels. 1. When setting a label inside a task and confirming the label creation with enter, the labels disappear from the list until the list is reloaded 1. When editing the color of a Label in the Label editor, the color change applies directly, and seems saved, but on reload all changes are reverted. 1. The Tags don't seem do be sorted in any way making it difficult to maintain an overview. 1. Maybe Add an ability to group the Tags by Namespace/List they are in?
konrad added the
kind/bug
kind/feature
labels 2 weeks ago
Owner

When setting a label inside a task and confirming the label creation with enter, the labels disappear from the list until the list is reloaded

When editing the color of a Label in the Label editor, the color change applies directly, and seems saved, but on reload all changes are reverted.

I can confirm those two are bugs.

The Tags don't seem do be sorted in any way making it difficult to maintain an overview.

Maybe sorting them alphabetically would work?

Maybe Add an ability to group the Tags by Namespace/List they are in?

The problem here is that labels are not associated to a namespace or list but tasks. To make them show up grouped by the list or namespace they are in would require api changes and may make labels show up multiple times.

> When setting a label inside a task and confirming the label creation with enter, the labels disappear from the list until the list is reloaded > When editing the color of a Label in the Label editor, the color change applies directly, and seems saved, but on reload all changes are reverted. I can confirm those two are bugs. > The Tags don't seem do be sorted in any way making it difficult to maintain an overview. Maybe sorting them alphabetically would work? > Maybe Add an ability to group the Tags by Namespace/List they are in? The problem here is that labels are not associated to a namespace or list but tasks. To make them show up grouped by the list or namespace they are in would require api changes and may make labels show up multiple times.
Poster

Maybe sorting them alphabetically would work?

Sounds fine by me, in general some sorting also in the sidebar and so on can help get through clutter and finding something in a bigger namespace/list, but I'm more than happy with sorted labels :)

Also maybe sort them in the list/kanban view. Isn't a big issue, but rather eye candy ^^
image

> Maybe sorting them alphabetically would work? Sounds fine by me, in general some sorting also in the sidebar and so on can help get through clutter and finding something in a bigger namespace/list, but I'm more than happy with sorted labels :) Also maybe sort them in the list/kanban view. Isn't a big issue, but rather eye candy ^^ ![image](/attachments/604e4c9f-e11c-4092-817e-6e1c5d37b8d7)
Owner

Fixed the bugs and sorting stuff in cf25e96c50, 926d7938ab, fe4a8c17c8 and 83b530b8ba.

CI is running and building a new unstable build with the changes.

I think this is resolved now, closing. Feel free to reopen or ping me if you feel there's other issues with it.

Fixed the bugs and sorting stuff in cf25e96c509675b8a1e2113505468ee39d7e8fc2, 926d7938ab932cac01d7b83708e42b6342e24a3f, fe4a8c17c8a07b72f5b0504670f461a8b97969c8 and 83b530b8ba8256bba8cb012e67aed382496f6f2e. [CI is running](https://drone.kolaente.de/vikunja/frontend/2397) and building a new unstable build with the changes. I think this is resolved now, closing. Feel free to reopen or ping me if you feel there's other issues with it.
konrad closed this issue 2 weeks ago
Poster

The bugs seem to be fixed, but the sorting didn't seem to take effect yet.
Do I somehow need to update those in particular or is that just coming during the next update?
image

The bugs seem to be fixed, but the sorting didn't seem to take effect yet. Do I somehow need to update those in particular or is that just coming during the next update? ![image](/attachments/2d612bc8-0707-47cb-832a-92ae398807d2)
Gensokian reopened this issue 2 weeks ago
Owner

What version are you on? Can you reproduce that on try? Sorting works for me on try.

I can't open the screenshot so I don't know what exactly doesnt work.

What version are you on? Can you reproduce that on try? Sorting works for me on try. I can't open the screenshot so I don't know what exactly doesnt work.
Poster

I tried it out on "TRY" but it seems as it isn't sorting there, either

Label Overview

image

Inside Task

image

On Listview

image

On Kanbanview

image

I tried it out on "TRY" but it seems as it isn't sorting there, either ### Label Overview ![image](/attachments/22b74180-e776-4767-b822-8a7f15e3f40b) ### Inside Task ![image](/attachments/aa896e3f-74f8-4c31-9125-7906bc9761ec) ### On Listview ![image](/attachments/7284800e-1c00-41cd-bf68-0d0d0770fbc1) ### On Kanbanview ![image](/attachments/ca73646b-27cf-4673-ace8-7094ea66e239)
Owner

Looks sorted to me:
image
image
image
image

That's probably a caching issue. Try clearing your browser cache and that little "update" button on the top right if it appears. Or open it in a private window.

Looks sorted to me: ![image](/attachments/b7bad19d-dbe9-4be3-aaf1-a6c3f7522f52) ![image](/attachments/2f5b74b5-6351-4747-9c56-fb480a250ce5) ![image](/attachments/932797a1-f2a0-4583-868d-7ffee48581bf) ![image](/attachments/964697c9-d4e8-4ba4-9c66-a4044d1c7e85) That's probably a caching issue. Try clearing your browser cache and that little "update" button on the top right if it appears. Or open it in a private window.
Poster

So I thought the same thing, but funnily enough, that is not the case

Top Left: Private/Inkognito browser
Bottom Left: Same but with the version info
Top Right: The Docker Image
Bottom right: The same list, but running in a sandbox

image

So I thought the same thing, but funnily enough, that is not the case Top Left: Private/Inkognito browser Bottom Left: Same but with the version info Top Right: The Docker Image Bottom right: The same list, but running in a sandbox ![image](/attachments/5428f9e3-e902-404a-b421-54ed5874ba05)
570 KiB
Owner

Hm that's weired. Ist there anying in the browser console?

Hm that's weired. Ist there anying in the browser console?
Poster

image

I've shortly re-updated the server and recieved a refresh event. But else this doesn't load... How would I refresh the cached version on the server?

![image](/attachments/10e3690f-d983-4e1c-8a61-2e1679b7aadc) I've shortly re-updated the server and recieved a refresh event. But else this doesn't load... How would I refresh the cached version on the server?
Owner

You can try a few things:

  • Reloading the page with ctrl-F5
  • In the dev tools in the "application" tab, unregister the service worker and reload the page
  • In the dev tools in the "network" tab check the "disable cache" checkbox
  • Open the page in a private tab
  • A combination of the above
You can try a few things: * Reloading the page with `ctrl-F5` * In the dev tools in the "application" tab, unregister the service worker and reload the page * In the dev tools in the "network" tab check the "disable cache" checkbox * Open the page in a private tab * A combination of the above
Poster

Odd, even on a private tab, uncached, and re-registered Worker tab it just doesn't want to sort...

What is strange to me is, on another browser and even another virtual machine it doesn't sort, either.

Odd, even on a private tab, uncached, and re-registered Worker tab it just doesn't want to sort... What is strange to me is, on another browser and even another virtual machine it doesn't sort, either.
Owner

And is the version correct on that other browser?

And is the version correct on that other browser?
Poster

image
Oddly enough, yes.

Tested on Vivaldi, Edge and Edge in a "Windows Sandbox"

![image](/attachments/5125d591-2640-4acf-9cfd-d891e8878e9a) Oddly enough, yes. Tested on Vivaldi, Edge and Edge in a "Windows Sandbox"
Owner

And it does not work either on try?

And it does not work either on try?
Poster

image

Just created some labels on try, didn't seem to work out. (Unless T comes before A ;) )
Note: This was now also tested on another computer.

![image](/attachments/853ce52a-6d8f-4337-bfc4-8a946df8eee6) Just created some labels on try, didn't seem to work out. (Unless T comes before A ;) ) Note: This was now also tested on another computer.
Owner

Still not reproducable for me: image (Firefox 89, Chromium 91)

However, on my Windows VM in Chrome (Firefox works):
image

So I guess that's a Windows-specific bug. I'll investigate.

Still not reproducable for me: ![image](/attachments/0523940c-6510-4fd6-9c72-ac928fc3790e) (Firefox 89, Chromium 91) However, on my Windows VM in Chrome (Firefox works): ![image](/attachments/aefd5f9d-1c3c-40cc-9d09-4043dbf5c74d) So I guess that's a Windows-specific bug. I'll investigate.
konrad referenced this issue from a commit 1 week ago
konrad closed this issue 1 week ago
Owner

Should be fixed in fd5d331eca.

I don't really understand why this was only an issue in chromium on Windows and not on Linux. The solution is somewhat interesting: https://stackoverflow.com/a/1969200/10924593.

Please test it once the CI released a new unstable release.

Should be fixed in https://kolaente.dev/vikunja/frontend/commit/fd5d331eca613849263506bc3360ae0e2589a966. I don't really understand why this was only an issue in chromium on Windows and not on Linux. The solution is somewhat interesting: https://stackoverflow.com/a/1969200/10924593. Please test it once [the CI](https://drone.kolaente.de/vikunja/frontend/2455) released a new unstable release.
Poster

Yep, now it works perfectly! Thanks a bunch!

Yep, now it works perfectly! Thanks a bunch!
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.