Dependency Dashboard #1848

Open
opened 2021-10-15 20:08:05 +00:00 by renovate · 0 comments
Member

This issue lists Renovate updates and detected dependencies. Read the Dependency Dashboard docs to learn more.

Edited/Blocked

These updates have been manually edited so Renovate will no longer make changes. To discard all commits and start over, click on a checkbox.

Open

These updates have all been created already. Click a checkbox below to force a retry/rebase of any.

Detected dependencies

docker-compose
frontend/cypress/docker-compose.yml
dockerfile
Dockerfile
  • docker/dockerfile 1
  • node 20.14.0-alpine
docs/Dockerfile
droneci
.drone.yml
  • mariadb 11
  • mariadb 11
  • mariadb 11
  • postgres 16
  • postgres 16
  • postgres 16
  • golangci/golangci-lint v1.59.1
  • node 20.14.0-alpine
  • node 20.14.0-alpine
  • node 20.14.0-alpine
  • node 20.14.0-alpine
  • node 20.14.0-alpine
  • node 20.14.0-alpine
  • node 20.14.0-alpine
  • plugins/gpgsign 1
  • goreleaser/nfpm v2.37.1
  • goreleaser/nfpm v2.37.1
  • node 20.14.0-alpine
  • node 20.14.0-alpine
  • klakegg/hugo 0.111.3
github-actions
.github/workflows/lockdown.yml
  • dessant/repo-lockdown v4
gomod
go.mod
  • dario.cat/mergo v1.0.0
  • github.com/ThreeDotsLabs/watermill v1.3.5
  • github.com/adlio/trello v1.12.0
  • github.com/arran4/golang-ical v0.3.0
  • github.com/bbrks/go-blurhash v1.1.1
  • github.com/coreos/go-oidc/v3 v3.10.0
  • github.com/cweill/gotests v1.6.0
  • github.com/d4l3k/messagediff v1.2.1
  • github.com/disintegration/imaging v1.6.2
  • github.com/gabriel-vasile/mimetype v1.4.4
  • github.com/ganigeorgiev/fexpr v0.4.1
  • github.com/getsentry/sentry-go v0.28.1
  • github.com/go-sql-driver/mysql v1.8.1
  • github.com/go-testfixtures/testfixtures/v3 v3.11.0
  • github.com/golang-jwt/jwt/v5 v5.2.1
  • github.com/google/uuid v1.6.0
  • github.com/hashicorp/go-version v1.7.0
  • github.com/iancoleman/strcase v0.3.0
  • github.com/jinzhu/copier v0.4.0
  • github.com/labstack/echo-jwt/v4 v4.2.0
  • github.com/labstack/echo/v4 v4.12.0
  • github.com/labstack/gommon v0.4.2
  • github.com/lib/pq v1.10.9
  • github.com/magefile/mage v1.15.0
  • github.com/mattn/go-sqlite3 v1.14.22
  • github.com/microcosm-cc/bluemonday v1.0.26
  • github.com/olekukonko/tablewriter v0.0.5
  • github.com/pquerna/otp v1.4.0
  • github.com/prometheus/client_golang v1.19.1
  • github.com/redis/go-redis/v9 v9.5.3
  • github.com/robfig/cron/v3 v3.0.1
  • github.com/samedi/caldav-go v3.0.0+incompatible
  • github.com/spf13/afero v1.11.0
  • github.com/spf13/cobra v1.8.1
  • github.com/spf13/viper v1.19.0
  • github.com/stretchr/testify v1.9.0
  • github.com/swaggo/swag v1.16.3
  • github.com/tkuchiki/go-timezone v0.2.3
  • github.com/typesense/typesense-go v1.1.0
  • github.com/ulule/limiter/v3 v3.11.2
  • github.com/wneessen/go-mail v0.4.1
  • github.com/yuin/goldmark v1.7.2
  • golang.org/x/crypto v0.24.0
  • golang.org/x/image v0.17.0
  • golang.org/x/oauth2 v0.21.0
  • golang.org/x/sync v0.7.0
  • golang.org/x/sys v0.21.0
  • golang.org/x/term v0.21.0
  • golang.org/x/text v0.16.0
  • gopkg.in/d4l3k/messagediff.v1 v1.2.1
  • gopkg.in/yaml.v3 v3.0.1
  • mvdan.cc/xurls/v2 v2.5.0
  • src.techknowlogick.com/xormigrate v1.7.1
  • xorm.io/builder v0.3.13
  • xorm.io/xorm v1.3.9
  • go 1.21
  • go 1.22.4
npm
desktop/package.json
  • connect-history-api-fallback 2.0.0
  • express 4.19.2
  • electron 29.4.2
  • electron-builder 24.13.3
frontend/package.json
  • @fortawesome/fontawesome-svg-core 6.5.2
  • @fortawesome/free-regular-svg-icons 6.5.2
  • @fortawesome/free-solid-svg-icons 6.5.2
  • @fortawesome/vue-fontawesome 3.0.8
  • @github/hotkey 3.1.0
  • @infectoone/vue-ganttastic 2.3.2
  • @intlify/unplugin-vue-i18n 4.0.0
  • @kyvg/vue3-notification 3.2.1
  • @sentry/tracing 7.114.0
  • @sentry/vue 8.10.0
  • @tiptap/core 2.4.0
  • @tiptap/extension-blockquote 2.4.0
  • @tiptap/extension-bold 2.4.0
  • @tiptap/extension-bullet-list 2.4.0
  • @tiptap/extension-code 2.4.0
  • @tiptap/extension-code-block-lowlight 2.4.0
  • @tiptap/extension-document 2.4.0
  • @tiptap/extension-dropcursor 2.4.0
  • @tiptap/extension-gapcursor 2.4.0
  • @tiptap/extension-hard-break 2.4.0
  • @tiptap/extension-heading 2.4.0
  • @tiptap/extension-history 2.4.0
  • @tiptap/extension-horizontal-rule 2.4.0
  • @tiptap/extension-image 2.4.0
  • @tiptap/extension-italic 2.4.0
  • @tiptap/extension-link 2.4.0
  • @tiptap/extension-list-item 2.4.0
  • @tiptap/extension-ordered-list 2.4.0
  • @tiptap/extension-paragraph 2.4.0
  • @tiptap/extension-placeholder 2.4.0
  • @tiptap/extension-strike 2.4.0
  • @tiptap/extension-table 2.4.0
  • @tiptap/extension-table-cell 2.4.0
  • @tiptap/extension-table-header 2.4.0
  • @tiptap/extension-table-row 2.4.0
  • @tiptap/extension-task-item 2.4.0
  • @tiptap/extension-task-list 2.4.0
  • @tiptap/extension-text 2.4.0
  • @tiptap/extension-typography 2.4.0
  • @tiptap/extension-underline 2.4.0
  • @tiptap/pm 2.4.0
  • @tiptap/suggestion 2.4.0
  • @tiptap/vue-3 2.4.0
  • @types/is-touch-device 1.0.2
  • @types/lodash.clonedeep 4.5.9
  • @vueuse/core 10.11.0
  • @vueuse/router 10.11.0
  • axios 1.7.2
  • blurhash 2.0.5
  • bulma-css-variables 0.9.33
  • change-case 5.4.4
  • date-fns 3.6.0
  • dayjs 1.11.11
  • dompurify 3.1.5
  • fast-deep-equal 3.1.3
  • flatpickr 4.6.13
  • flexsearch 0.7.31
  • floating-vue 5.2.2
  • is-touch-device 1.0.1
  • klona 2.0.6
  • lodash.debounce 4.0.8
  • lowlight 2.9.0
  • pinia 2.1.7
  • register-service-worker 1.7.2
  • sortablejs 1.15.2
  • tippy.js 6.3.7
  • ufo 1.5.3
  • vue 3.4.29
  • vue-advanced-cropper 2.8.9
  • vue-flatpickr-component 11.0.5
  • vue-i18n 9.13.1
  • vue-router 4.3.3
  • vuemoji-picker 0.2.1
  • workbox-precaching 7.1.0
  • zhyswan-vuedraggable 4.1.3
  • @4tw/cypress-drag-drop 2.2.5
  • @cypress/vite-dev-server 5.1.1
  • @cypress/vue 6.0.1
  • @faker-js/faker 8.4.1
  • @histoire/plugin-screenshot 0.17.17
  • @histoire/plugin-vue 0.17.17
  • @rushstack/eslint-patch 1.10.3
  • @tsconfig/node20 20.1.4
  • @types/codemirror 5.60.15
  • @types/dompurify 3.0.5
  • @types/flexsearch 0.7.6
  • @types/is-touch-device 1.0.2
  • @types/lodash.debounce 4.0.9
  • @types/node 20.14.5
  • @types/sortablejs 1.15.8
  • @typescript-eslint/eslint-plugin 7.13.1
  • @typescript-eslint/parser 7.13.1
  • @vitejs/plugin-legacy 5.4.1
  • @vitejs/plugin-vue 5.0.5
  • @vue/eslint-config-typescript 13.0.0
  • @vue/test-utils 2.4.6
  • @vue/tsconfig 0.5.1
  • autoprefixer 10.4.19
  • browserslist 4.23.1
  • caniuse-lite 1.0.30001636
  • csstype 3.1.3
  • cypress 13.12.0
  • esbuild 0.21.5
  • eslint 8.57.0
  • eslint-plugin-vue 9.26.0
  • happy-dom 14.12.0
  • histoire 0.17.17
  • postcss 8.4.38
  • postcss-easing-gradients 3.0.1
  • postcss-easings 4.0.0
  • postcss-preset-env 9.5.14
  • rollup 4.18.0
  • rollup-plugin-visualizer 5.12.0
  • sass 1.77.6
  • start-server-and-test 2.0.4
  • typescript 5.4.5
  • unplugin-inject-preload 2.0.4
  • vite 5.3.1
  • vite-plugin-pwa 0.20.0
  • vite-plugin-sentry 1.4.0
  • vite-svg-loader 5.1.0
  • vitest 1.6.0
  • vue-tsc 2.0.21
  • wait-on 7.2.0
  • workbox-cli 7.1.0
  • pnpm 9.4.0
nvm
frontend/.nvmrc
  • node 20.14.0
This issue lists Renovate updates and detected dependencies. Read the [Dependency Dashboard](https://docs.renovatebot.com/key-concepts/dashboard/) docs to learn more. ## Edited/Blocked These updates have been manually edited so Renovate will no longer make changes. To discard all commits and start over, click on a checkbox. - [ ] <!-- rebase-branch=renovate/major-dev-dependencies -->[chore(deps): update dev-dependencies (major)](pulls/2260) (`electron`, `eslint`) ## Open These updates have all been created already. Click a checkbox below to force a retry/rebase of any. - [ ] <!-- rebase-branch=renovate/dev-dependencies -->[chore(deps): update dependency @types/node to v20.14.6](pulls/2448) - [ ] <!-- rebase-branch=renovate/github-hotkey-3.x -->[fix(deps): update dependency @github/hotkey to v3.1.1](pulls/2329) - [ ] <!-- rebase-branch=renovate/flexsearch-0.x -->[fix(deps): update dependency flexsearch to v0.7.43](pulls/2095) - [ ] <!-- rebase-branch=renovate/lowlight-3.x -->[fix(deps): update dependency lowlight to v3](pulls/2107) - [ ] <!-- rebase-all-open-prs -->**Click on this checkbox to rebase all open PRs at once** ## Detected dependencies <details><summary>docker-compose</summary> <blockquote> <details><summary>frontend/cypress/docker-compose.yml</summary> </details> </blockquote> </details> <details><summary>dockerfile</summary> <blockquote> <details><summary>Dockerfile</summary> - `docker/dockerfile 1` - `node 20.14.0-alpine` </details> <details><summary>docs/Dockerfile</summary> </details> </blockquote> </details> <details><summary>droneci</summary> <blockquote> <details><summary>.drone.yml</summary> - `mariadb 11` - `mariadb 11` - `mariadb 11` - `postgres 16` - `postgres 16` - `postgres 16` - `golangci/golangci-lint v1.59.1` - `node 20.14.0-alpine` - `node 20.14.0-alpine` - `node 20.14.0-alpine` - `node 20.14.0-alpine` - `node 20.14.0-alpine` - `node 20.14.0-alpine` - `node 20.14.0-alpine` - `plugins/gpgsign 1` - `goreleaser/nfpm v2.37.1` - `goreleaser/nfpm v2.37.1` - `node 20.14.0-alpine` - `node 20.14.0-alpine` - `klakegg/hugo 0.111.3` </details> </blockquote> </details> <details><summary>github-actions</summary> <blockquote> <details><summary>.github/workflows/lockdown.yml</summary> - `dessant/repo-lockdown v4` </details> </blockquote> </details> <details><summary>gomod</summary> <blockquote> <details><summary>go.mod</summary> - `dario.cat/mergo v1.0.0` - `github.com/ThreeDotsLabs/watermill v1.3.5` - `github.com/adlio/trello v1.12.0` - `github.com/arran4/golang-ical v0.3.0` - `github.com/bbrks/go-blurhash v1.1.1` - `github.com/coreos/go-oidc/v3 v3.10.0` - `github.com/cweill/gotests v1.6.0` - `github.com/d4l3k/messagediff v1.2.1` - `github.com/disintegration/imaging v1.6.2` - `github.com/gabriel-vasile/mimetype v1.4.4` - `github.com/ganigeorgiev/fexpr v0.4.1` - `github.com/getsentry/sentry-go v0.28.1` - `github.com/go-sql-driver/mysql v1.8.1` - `github.com/go-testfixtures/testfixtures/v3 v3.11.0` - `github.com/golang-jwt/jwt/v5 v5.2.1` - `github.com/google/uuid v1.6.0` - `github.com/hashicorp/go-version v1.7.0` - `github.com/iancoleman/strcase v0.3.0` - `github.com/jinzhu/copier v0.4.0` - `github.com/labstack/echo-jwt/v4 v4.2.0` - `github.com/labstack/echo/v4 v4.12.0` - `github.com/labstack/gommon v0.4.2` - `github.com/lib/pq v1.10.9` - `github.com/magefile/mage v1.15.0` - `github.com/mattn/go-sqlite3 v1.14.22` - `github.com/microcosm-cc/bluemonday v1.0.26` - `github.com/olekukonko/tablewriter v0.0.5` - `github.com/pquerna/otp v1.4.0` - `github.com/prometheus/client_golang v1.19.1` - `github.com/redis/go-redis/v9 v9.5.3` - `github.com/robfig/cron/v3 v3.0.1` - `github.com/samedi/caldav-go v3.0.0+incompatible` - `github.com/spf13/afero v1.11.0` - `github.com/spf13/cobra v1.8.1` - `github.com/spf13/viper v1.19.0` - `github.com/stretchr/testify v1.9.0` - `github.com/swaggo/swag v1.16.3` - `github.com/tkuchiki/go-timezone v0.2.3` - `github.com/typesense/typesense-go v1.1.0` - `github.com/ulule/limiter/v3 v3.11.2` - `github.com/wneessen/go-mail v0.4.1` - `github.com/yuin/goldmark v1.7.2` - `golang.org/x/crypto v0.24.0` - `golang.org/x/image v0.17.0` - `golang.org/x/oauth2 v0.21.0` - `golang.org/x/sync v0.7.0` - `golang.org/x/sys v0.21.0` - `golang.org/x/term v0.21.0` - `golang.org/x/text v0.16.0` - `gopkg.in/d4l3k/messagediff.v1 v1.2.1` - `gopkg.in/yaml.v3 v3.0.1` - `mvdan.cc/xurls/v2 v2.5.0` - `src.techknowlogick.com/xormigrate v1.7.1` - `xorm.io/builder v0.3.13` - `xorm.io/xorm v1.3.9` - `go 1.21` - `go 1.22.4` </details> </blockquote> </details> <details><summary>npm</summary> <blockquote> <details><summary>desktop/package.json</summary> - `connect-history-api-fallback 2.0.0` - `express 4.19.2` - `electron 29.4.2` - `electron-builder 24.13.3` </details> <details><summary>frontend/package.json</summary> - `@fortawesome/fontawesome-svg-core 6.5.2` - `@fortawesome/free-regular-svg-icons 6.5.2` - `@fortawesome/free-solid-svg-icons 6.5.2` - `@fortawesome/vue-fontawesome 3.0.8` - `@github/hotkey 3.1.0` - `@infectoone/vue-ganttastic 2.3.2` - `@intlify/unplugin-vue-i18n 4.0.0` - `@kyvg/vue3-notification 3.2.1` - `@sentry/tracing 7.114.0` - `@sentry/vue 8.10.0` - `@tiptap/core 2.4.0` - `@tiptap/extension-blockquote 2.4.0` - `@tiptap/extension-bold 2.4.0` - `@tiptap/extension-bullet-list 2.4.0` - `@tiptap/extension-code 2.4.0` - `@tiptap/extension-code-block-lowlight 2.4.0` - `@tiptap/extension-document 2.4.0` - `@tiptap/extension-dropcursor 2.4.0` - `@tiptap/extension-gapcursor 2.4.0` - `@tiptap/extension-hard-break 2.4.0` - `@tiptap/extension-heading 2.4.0` - `@tiptap/extension-history 2.4.0` - `@tiptap/extension-horizontal-rule 2.4.0` - `@tiptap/extension-image 2.4.0` - `@tiptap/extension-italic 2.4.0` - `@tiptap/extension-link 2.4.0` - `@tiptap/extension-list-item 2.4.0` - `@tiptap/extension-ordered-list 2.4.0` - `@tiptap/extension-paragraph 2.4.0` - `@tiptap/extension-placeholder 2.4.0` - `@tiptap/extension-strike 2.4.0` - `@tiptap/extension-table 2.4.0` - `@tiptap/extension-table-cell 2.4.0` - `@tiptap/extension-table-header 2.4.0` - `@tiptap/extension-table-row 2.4.0` - `@tiptap/extension-task-item 2.4.0` - `@tiptap/extension-task-list 2.4.0` - `@tiptap/extension-text 2.4.0` - `@tiptap/extension-typography 2.4.0` - `@tiptap/extension-underline 2.4.0` - `@tiptap/pm 2.4.0` - `@tiptap/suggestion 2.4.0` - `@tiptap/vue-3 2.4.0` - `@types/is-touch-device 1.0.2` - `@types/lodash.clonedeep 4.5.9` - `@vueuse/core 10.11.0` - `@vueuse/router 10.11.0` - `axios 1.7.2` - `blurhash 2.0.5` - `bulma-css-variables 0.9.33` - `change-case 5.4.4` - `date-fns 3.6.0` - `dayjs 1.11.11` - `dompurify 3.1.5` - `fast-deep-equal 3.1.3` - `flatpickr 4.6.13` - `flexsearch 0.7.31` - `floating-vue 5.2.2` - `is-touch-device 1.0.1` - `klona 2.0.6` - `lodash.debounce 4.0.8` - `lowlight 2.9.0` - `pinia 2.1.7` - `register-service-worker 1.7.2` - `sortablejs 1.15.2` - `tippy.js 6.3.7` - `ufo 1.5.3` - `vue 3.4.29` - `vue-advanced-cropper 2.8.9` - `vue-flatpickr-component 11.0.5` - `vue-i18n 9.13.1` - `vue-router 4.3.3` - `vuemoji-picker 0.2.1` - `workbox-precaching 7.1.0` - `zhyswan-vuedraggable 4.1.3` - `@4tw/cypress-drag-drop 2.2.5` - `@cypress/vite-dev-server 5.1.1` - `@cypress/vue 6.0.1` - `@faker-js/faker 8.4.1` - `@histoire/plugin-screenshot 0.17.17` - `@histoire/plugin-vue 0.17.17` - `@rushstack/eslint-patch 1.10.3` - `@tsconfig/node20 20.1.4` - `@types/codemirror 5.60.15` - `@types/dompurify 3.0.5` - `@types/flexsearch 0.7.6` - `@types/is-touch-device 1.0.2` - `@types/lodash.debounce 4.0.9` - `@types/node 20.14.5` - `@types/sortablejs 1.15.8` - `@typescript-eslint/eslint-plugin 7.13.1` - `@typescript-eslint/parser 7.13.1` - `@vitejs/plugin-legacy 5.4.1` - `@vitejs/plugin-vue 5.0.5` - `@vue/eslint-config-typescript 13.0.0` - `@vue/test-utils 2.4.6` - `@vue/tsconfig 0.5.1` - `autoprefixer 10.4.19` - `browserslist 4.23.1` - `caniuse-lite 1.0.30001636` - `csstype 3.1.3` - `cypress 13.12.0` - `esbuild 0.21.5` - `eslint 8.57.0` - `eslint-plugin-vue 9.26.0` - `happy-dom 14.12.0` - `histoire 0.17.17` - `postcss 8.4.38` - `postcss-easing-gradients 3.0.1` - `postcss-easings 4.0.0` - `postcss-preset-env 9.5.14` - `rollup 4.18.0` - `rollup-plugin-visualizer 5.12.0` - `sass 1.77.6` - `start-server-and-test 2.0.4` - `typescript 5.4.5` - `unplugin-inject-preload 2.0.4` - `vite 5.3.1` - `vite-plugin-pwa 0.20.0` - `vite-plugin-sentry 1.4.0` - `vite-svg-loader 5.1.0` - `vitest 1.6.0` - `vue-tsc 2.0.21` - `wait-on 7.2.0` - `workbox-cli 7.1.0` - `pnpm 9.4.0` </details> </blockquote> </details> <details><summary>nvm</summary> <blockquote> <details><summary>frontend/.nvmrc</summary> - `node 20.14.0` </details> </blockquote> </details>
konrad added the
dependencies
label 2021-10-16 07:31:02 +00:00
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: vikunja/vikunja#1848
No description provided.